Blog Programistyczny

Branżowy blog dla Webmastera.

PHP Systemy CMS WordPress

WordPress – problem przy instalacji nowej wtyczki lub aktualizacji – prośba o połączenie FTP

Jeśli używamy serwera lokalnego LAMP i instalujemy na nim stronę CMS opartą o WordPress możemy natknąć się na błąd z instalacją nowej wtyczki:

Aby wykonać wybrane działanie, WordPress potrzebuje dostępu do twojego serwera WWW. Wprowadź dane połączenia FTP, aby kontynuować. Jeśli nie pamiętasz danych do połączenia się, skontaktuj się z administratorem swojego serwera.

Objawia się to wyświetleniem tego okna:

Oraz wtyczka nie może być pobrana przez system WP.

Jest prosty sposób aby to naprawić. Otwórz plik:

Znajduje się on w głównym folderze instalacji i pod kodem:

Wklej poniższą linijkę:

Po tej operacji wgraj zmieniony plik PHP i odśwież stronę do pobierania wtyczek. Problem powinien zniknąć 😉

grafika: alphacoders.com

Recommended
Przekierowanie na szybko z HTTP na HTTPS - jak to…
Cresta Posts Box by CP